Video Player

Benutzeravatar
dummy
Kámi-sama
Kámi-sama
Beiträge: 556
Registriert: 29.12.2007 10:35
Gruppe: ASU
Wohnort: kleiner Satellit, hinterm Mond
Kontaktdaten:

Video Player

Beitragvon dummy » 22.02.2008 02:17

Mir ist aufgefallen, dass manche Dateien mit unterschiedlichen Playern anders abgespielt werden. Manche Avi und Divx werden mit dem Mediaplayer Classic auf meinem Rechner zu langsam abgespielt, sodass der Ton meist voraus läuft. Dafür kann der VLC Player die Dateien perfekt in normaler Geschwindigkeit abspielen, zeigt aber die Untertitel völlig falsch an. Manchmal überschneiden sich die Untertitel. Hab eigentlich einen recht schnellen Rechner, an der Hardware liegt es nicht, dass der Mediaplayer bei manchen Dateien in die Knie geht. Bei Pokaan zb. Kann ich manche Files erst garnicht mit dem CMP starten und mit VLC Stürzt das Programm manchmal ab. Ich merke es, wenn plötzlich keine Untertitel mehr kommen, dann weiß ich, dass in wenigen Sekunden sich das Programm verabschiedet.

Wollte mal Fragen, ob dieses Phänomen bei euch bekannt ist und was ihr dagegen so unternehmt.
Bild Bild Bild
Ich mag Photoshop ^^.

Benutzeravatar
Rei_Battlecake
Gruppenleader
Gruppenleader
Beiträge: 1061
Registriert: 30.12.2007 22:13
Gruppe: Gruppe Kampfkuchen
Wohnort: Kuchenbasis
Kontaktdaten:

Re: Video Player

Beitragvon Rei_Battlecake » 22.02.2008 10:34

Zoomplayer benutzen und alles klappt wunderbar, das kannste dagegen unternehmen.
Bild
"Der Mensch braucht nur eines im Leben, jemanden den er lieben kann, kannst du ihm das nicht geben, gib ihm Hoffnung, kannst du ihm das auch nicht geben, gib ihm was zu tun."

Man könnte ja mal wieder was subben

Benutzeravatar
dummy
Kámi-sama
Kámi-sama
Beiträge: 556
Registriert: 29.12.2007 10:35
Gruppe: ASU
Wohnort: kleiner Satellit, hinterm Mond
Kontaktdaten:

Re: Video Player

Beitragvon dummy » 22.02.2008 14:22

Kann man damit auch Screenshots machen und Streamen?
Bild Bild Bild
Ich mag Photoshop ^^.

Benutzeravatar
Rei_Battlecake
Gruppenleader
Gruppenleader
Beiträge: 1061
Registriert: 30.12.2007 22:13
Gruppe: Gruppe Kampfkuchen
Wohnort: Kuchenbasis
Kontaktdaten:

Re: Video Player

Beitragvon Rei_Battlecake » 22.02.2008 14:39

ALT+F ist screenshot, streamen sollte auch gehen, lies doch mal die optionen durch oder so ;p
Bild
"Der Mensch braucht nur eines im Leben, jemanden den er lieben kann, kannst du ihm das nicht geben, gib ihm Hoffnung, kannst du ihm das auch nicht geben, gib ihm was zu tun."

Man könnte ja mal wieder was subben

Benutzeravatar
Kaoru_Battlemuffin
Senpai
Senpai
Beiträge: 143
Registriert: 29.12.2007 21:35
Gruppe: Gruppe Kampfkuchen

Re: Video Player

Beitragvon Kaoru_Battlemuffin » 22.02.2008 15:10

Der VLC kann nur gut abspielen weil er eigene Codecs nutzt. Daher meiner Meinung nach falsche Codecs.

Lösung: Alles runter -> CCCP Installieren -> Spaß haben
Bild
Bild

Use CCCP9+9, Codename "NEIN NEIN NEIN"

Benutzeravatar
Devil Doll
Kámi-sama
Kámi-sama
Beiträge: 584
Registriert: 30.12.2007 00:18
Gruppe: Devil Doll
Kontaktdaten:

Re: Video Player

Beitragvon Devil Doll » 22.02.2008 15:18

dummy hat geschrieben:Manche Avi und Divx werden mit dem Mediaplayer Classic auf meinem Rechner zu langsam abgespielt, sodass der Ton meist voraus läuft.
Zu so pauschalen Aussagen wirst Du nur pauschale Antworten erhalten. Wenn das Bild langsamer läuft als der Ton, dies aber nur in bestimmten Playern, würde ich auf Überlastung des Rechners tippen; für konkrete Hinweise wären aber konkrete Angaben über die betroffenen Container erforderlich, bevorzugt MediaInfo-Logs.

Benutzeravatar
dummy
Kámi-sama
Kámi-sama
Beiträge: 556
Registriert: 29.12.2007 10:35
Gruppe: ASU
Wohnort: kleiner Satellit, hinterm Mond
Kontaktdaten:

Re: Video Player

Beitragvon dummy » 22.02.2008 16:30

Ich habe nach dem letzten Format eigentlich nur MPC, VLC, winamp und CCCP installiert. Andere Player und Codecpakete benutze ich nicht. Außer hin und wieder den W.Mediaplayer, der schon mit Windof geliefert wird. Das Format liegt erst 2-3 Monate zurück. Vielleicht sollte ich die Programme auf den neuesten Stand bringen, wenn es inzwischen etwas neueres gibt. Ich habe nicht das Gefühl, dass der Rechner ausgelastet ist, wenn ich die Problemvideos abspiele. Wenn ich das Fenster plötzlich kleiner mache, dann wird das Video für eine kurze Zeit über - schnell abgespielt. Bei Vollbild, merkt man, dass das Bild langsamer ist eigentlich nur an der Tonspur. Wäre es vielleicht möglich, dass mir ein Codec fehlt, und dieser mit anderen Codecs emuliert wird, oder soetwas in der Art?

Sobald ich wieder mit dem Rechner arbeite (Klingt komisch aber ich benutze unterschiedliche Rechner an unterschiedlichen Orten ^^), werde ich die Problemdateien mit dem Mediainfo Programm überprüfen.

Wenn der Zoomplayer das Gleiche kann, verzichte ich vielleicht auf VLC und MPC. Wäre schön, nur ein Programm für alles zu haben. Danke für den Tipp.
Bild Bild Bild
Ich mag Photoshop ^^.

Benutzeravatar
Jimbei
Anime Gucker
Anime Gucker
Beiträge: 71
Registriert: 31.12.2007 21:48

Re: Video Player

Beitragvon Jimbei » 22.02.2008 17:26

Vielleicht könnte dir das ja helfen: viewtopic.php?f=19&t=116&p=1964#p1964
Zuletzt geändert von Jimbei am 22.02.2008 22:27, insgesamt 1-mal geändert.

Benutzeravatar
Rei_Battlecake
Gruppenleader
Gruppenleader
Beiträge: 1061
Registriert: 30.12.2007 22:13
Gruppe: Gruppe Kampfkuchen
Wohnort: Kuchenbasis
Kontaktdaten:

Re: Video Player

Beitragvon Rei_Battlecake » 22.02.2008 18:21

Wenn du das cccp drauf hast, hast du den zplayer btw sowieso schon installiert, der ist da drin...
Bild
"Der Mensch braucht nur eines im Leben, jemanden den er lieben kann, kannst du ihm das nicht geben, gib ihm Hoffnung, kannst du ihm das auch nicht geben, gib ihm was zu tun."

Man könnte ja mal wieder was subben

Benutzeravatar
Onichi
Anime Gucker
Anime Gucker
Beiträge: 80
Registriert: 05.01.2008 15:22

Re: Video Player

Beitragvon Onichi » 22.02.2008 22:51

dummy hat geschrieben:Mir ist aufgefallen, dass manche Dateien mit unterschiedlichen Playern anders abgespielt werden. Manche Avi und Divx werden mit dem Mediaplayer Classic auf meinem Rechner zu langsam abgespielt, sodass der Ton meist voraus läuft. Dafür kann der VLC Player die Dateien perfekt in normaler Geschwindigkeit abspielen, zeigt aber die Untertitel völlig falsch an. Manchmal überschneiden sich die Untertitel. Hab eigentlich einen recht schnellen Rechner, an der Hardware liegt es nicht, dass der Mediaplayer bei manchen Dateien in die Knie geht. Bei Pokaan zb. Kann ich manche Files erst garnicht mit dem CMP starten und mit VLC Stürzt das Programm manchmal ab. Ich merke es, wenn plötzlich keine Untertitel mehr kommen, dann weiß ich, dass in wenigen Sekunden sich das Programm verabschiedet.

Wollte mal Fragen, ob dieses Phänomen bei euch bekannt ist und was ihr dagegen so unternehmt.


Das ist mir extrem bei HD - Filmen aufgfallen!
Ich musste mehrmals das video bis zum gesehenen, erneut einspielen, das diese Verzögerung wieder weg ist.
Beim Korean Media Player ist das selbe problem.
Beim VLC - Player hatte ich gar keine Probleme, das Programm ist aber nicht abgestürzt.

Aber das du das Problem bei divx hast, vermute ich aber auch das es vielleicht ehr an deinem Rechner liegt, Power, viren, oder anderen defekten.
Hast du vielleicht mal deine CPU Auslastung im Taskmanager beobachtet?
Codec, kommt nur infrage wenn er kein cccp hat.

Wäre schön, nur ein Programm für alles zu haben. Danke für den Tipp.


Das wünsche ich mir schon lange!

@Jimbei, nichts gegen diesen Player aber er ist sehr anfällig...
Bild

Benutzeravatar
Devil Doll
Kámi-sama
Kámi-sama
Beiträge: 584
Registriert: 30.12.2007 00:18
Gruppe: Devil Doll
Kontaktdaten:

Re: Video Player

Beitragvon Devil Doll » 23.02.2008 02:58

Onichi hat geschrieben:Das ist mir extrem bei HD - Filmen aufgfallen!
Was genau ein prima Kandidat für Überlastung des Rechners wäre. Deshalb wollte ich ja MediaInfo-Daten sehen, weil man daran erkennen kann, was eine konkretes Video von einem Rechner vermutlich an Leistung verlangen wird.

Benutzeravatar
Onichi
Anime Gucker
Anime Gucker
Beiträge: 80
Registriert: 05.01.2008 15:22

Re: Video Player

Beitragvon Onichi » 23.02.2008 12:10

Nicht wirklich wenn nur ein CpuKern angesprochen wird statt zweien dann liegt das ehr an der Programmierung, als an der Rechnerleistung.
Außerdem habe ich meine Cpu über den Taskmanger beobachten können, der eine Kern der angesprochen wird hat nur eine 50% Auslastung.
Also noch eine Menge reserven.
Ich vermute das liegt an der Programmierung(Codec und oder Programm), den der VLC - Player hat kein Problem diese Datei abzuspielen.
Und was ich da beobachten konnte, ist das zwei Kerne angesprochen werden. Da gibt es für diesen Player, Bounspunkte. *_*

Es sei den es wird die GPU mit in Anspruch genommen, da kann ich nichts sagen ob sie am Maximum liegt.

Aber beim divx kann ich mir nicht vorstellen das es ehr am CPU liegt.
Sehen wir mal ab. :)
Bild

Benutzeravatar
dummy
Kámi-sama
Kámi-sama
Beiträge: 556
Registriert: 29.12.2007 10:35
Gruppe: ASU
Wohnort: kleiner Satellit, hinterm Mond
Kontaktdaten:

Re: Video Player

Beitragvon dummy » 23.02.2008 12:23

Der Cmplayer schwankt bei der cpu zwischen 60 und 90 % Speicher wird nur wenig verbraucht ~23.5k.
Die selbe Datei lief bei mir mit dem CMP, soweit ich mich erinnern kann mal ohne Probleme.
Der VLC Player verbraucht 0% CPU und Speicher genauso wie der Cmplayer.
Zoom Player schwankt bei der CPU zwischen 10 und 25% und Speicherverbrauch ist ähnlich wie bei den anderen.

Ich habe es auf einem Notebook im Sparmodus (Akku) getestet Das entspricht dann etwa 797MHz.

Datei: avi
Bildfrequenz 23 Bilder/s
Datenrate 129 kBit/s
Videokomprimierung FFDS
Auflösung ist 640x480

Der CMP braucht ganz schön viel CPU Leistung. Ich kann mir vorstellen, dass wenn ich noch etwas Anderes im Hintergrund laufen habe, die CPU voll ausgelastet ist und deswegen, das Bild langsamer wird. Ist es denn normal, dass der CMP so viel Leistung braucht?
Bild Bild Bild
Ich mag Photoshop ^^.

Benutzeravatar
Onichi
Anime Gucker
Anime Gucker
Beiträge: 80
Registriert: 05.01.2008 15:22

Re: Video Player

Beitragvon Onichi » 23.02.2008 14:47

CMP = Cmplayer(?) meinst du damit den Korean Media Player = KMP
oder meinst du den Media Player Classic = MPC?

Ich habe noch eine Frage,
hast du schon mal deinen Rechner auf Viren oder anderen Säuchen untersucht,
dann könnte man schonmal das außer Beachtung lassen.

Auflösung ist 640x480


Wenn diese Video nicht unbedingt mit dem H264 encodiert wurde,
und dieses Video ganz schlecht auf deinem Rechner läuft,
dann kann es doch eigentlich nicht mehr am Player liegen.
Dann kann es nur an Viren liegen oder das deine Hardware irgendwie Probleme hat.

Mal schauen was die Anderen dazu sagen. o.0

Ich habe es auf einem Notebook im Sparmodus (Akku) getestet Das entspricht dann etwa 797MHz.

~800mhz ist wohl eine gute Umgebung um soetwas zu testen.

Ich kann Dich auch etwas trösten und dir sagen das ich fünf(sechs mit dem von MS) verschiedene Media Player aufm Rechner installiert habe.
Drei davon für individuelle Zwecke. :)

Den einen für Music
Den anderen für allg. alle Media Dateien
Und den Anderen wenn es mal irgendwo hapert.

:p
Bild

Benutzeravatar
Devil Doll
Kámi-sama
Kámi-sama
Beiträge: 584
Registriert: 30.12.2007 00:18
Gruppe: Devil Doll
Kontaktdaten:

Re: Video Player

Beitragvon Devil Doll » 23.02.2008 15:09

dummy hat geschrieben:Datei: avi
Bildfrequenz 23 Bilder/s
Datenrate 129 kBit/s
Videokomprimierung FFDS
Auflösung ist 640x480
FFDS? "Datenrate"? Kein Video mit 640*480px wird 129 kbit/sec haben (da könnte man nämlich nichts mehr erkennen vor lauter Artefakten).

Also: Bitte keine Werte erfinden, sondern die MediaInfo-Ausgabe hier posten.

Benutzeravatar
dummy
Kámi-sama
Kámi-sama
Beiträge: 556
Registriert: 29.12.2007 10:35
Gruppe: ASU
Wohnort: kleiner Satellit, hinterm Mond
Kontaktdaten:

Re: Video Player

Beitragvon dummy » 23.02.2008 16:03

Das habe ich aus den Eigenschaften der Datei.
1.jpg


Das gibt MediaInfo aus.:

Format : AVI
Format/Info : Audio Video Interleave
Format/Family : RIFF
Dateigröße : 173 MiB
Spielzeit : 22min
Bitrate : 1063 Kbps
StreamSize : 1.53 MiB
Verwendetes Programm : VirtualDubMod 1.5.10.2 (build 2542/release)
verwendete Encoder-Bibliothe : VirtualDubMod build 2542/release
--------------------------------------------------------------------------------------------
Codec : XviD
Codec/Family : MPEG-4V
Codec/Info : XviD project
Codec profile : Streaming Video Profile/Level 1
Codec settings, Packet bitst : Yes
Codec settings, BVOP : Yes
Codec settings, QPel : No
Codec settings, GMC : 0
Codec settings, Matrix : Default
Spielzeit : 22min
Bitrate : 926 Kbps
Breite : 640 Pixel
Höhe : 480 Pixel
Bildseitenverhältnis : 4/3
Bildwiederholungsrate : 23.976 FPS
Auflösung : 8 bits
Chroma : 4:2:0
Interlacement : Progressive
Bits/(Pixel*Frame) : 0.126
StreamSize : 150 MiB
---------------------------------------------------------------------
Codec : MPEG-1 Audio layer 3
Spielzeit : 22min
Bitraten-Modus : CBR
Bitrate : 128 Kbps
Kanäle : 2 Kanäle
Samplingrate : 48 KHz
Auflösung : 16 bits
Video0 Verzögerung : 24ms
StreamSize : 20.8 MiB
verwendete Encoder-Bibliothe : LAME3.92ª
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.
Bild Bild Bild
Ich mag Photoshop ^^.

Benutzeravatar
Devil Doll
Kámi-sama
Kámi-sama
Beiträge: 584
Registriert: 30.12.2007 00:18
Gruppe: Devil Doll
Kontaktdaten:

Re: Video Player

Beitragvon Devil Doll » 23.02.2008 16:51

dummy hat geschrieben:Codec/Family : MPEG-4V
Codec : XviD
Codec settings, Packet bitst : Yes
Codec settings, BVOP : Yes
Codec settings, QPel : No
Codec settings, GMC : 0
Codec settings, Matrix : Default
Bitrate : 926 Kbps
Breite : 640 Pixel
Höhe : 480 Pixel
Bildwiederholungsrate : 23.976 FPS
Interlacement : Progressive
---------------------------------------------------------------------
Codec : MPEG-1 Audio layer 3
Bitraten-Modus : CBR
Bitrate : 128 Kbps
Das sieht schon viel verständlicher aus als die Windows-eigene (irreführende) Anzeige von Eigenschaften... also ein Video mit Parametern, wie sie fast jeder normale Anime-Fansub in einem AVI-Container enthalten würde: XviD ohne komplizierte Zusatzeinstellungen (kein QPel, kein GMC3), eine Video-Bitrate im üblichen Bereich zwischen 600 und 1000 kb/sec, Standard-Bildformat, Standard-Bildwiederholungsrate, ein "gutartiger" Audio-Stream mit konstanter Bitrate.
Also im Wesentlichen ein Video, das praktisch jeder Standalone-Player problemlos abspielen würde und das an der Untergrenze dessen liegt, was Anime-Fansubs an Voraussetzungen verlangen. Wenn Du mit diesem Video Probleme beim Abspielen hast, dann solltest Du mit jedem anderen Anime-Fansub auch Probleme haben.

Ungewöhnlich sieht mir der Wert "Interlacement : Progressive" aus - bei sämtlichen XviD-Encodings, die ich hier herumliegen habe, steht an dieser Stelle "[PPF] Picture-per-field". Kannst Du mal vergleichen, ob sich Videos (konkret: XviD-Encodings in AVI-Containern), mit denen Du kein Problem hast, an genau dieser Stelle in den MediaInfo-Werten von dem vorliegenden Video unterscheiden? Falls damit nämlich beispielsweise das hier gemeint sein sollte, könnte ich mir vorstellen, dass das Abspielen solcher Videos einiges an Leistung erfordern sollte.

Benutzeravatar
jth
Neko-chan
Neko-chan
Beiträge: 30
Registriert: 31.12.2007 02:53
Gruppe: jth
Kontaktdaten:

Re: Video Player

Beitragvon jth » 24.02.2008 17:08

Mediainfo meint mit "Interlacement : Progressive" Vollbilder. Dennoch sollte das in dieser Aufllösung und Bitrate auch für ältere Rechner kein Problem darstellen.

Bei mir ist im Übrigen fast alles progressive was ich hier herumliegen habe.

Benutzeravatar
Devil Doll
Kámi-sama
Kámi-sama
Beiträge: 584
Registriert: 30.12.2007 00:18
Gruppe: Devil Doll
Kontaktdaten:

Re: Video Player

Beitragvon Devil Doll » 24.02.2008 18:28

Ich inzwischen auch, nachdem ich gerade auf die aktuelle Version von MediaInfo hochgerüstet habe. :shock:
Damit können wir diese Theorie zu Grabe tragen (und zurückkehren zur Einschätzung, dass das beschriebene Video so ziemlich der trivialste denkbare Fall ist, der überall problemlos abspielbar sein sollte).

Benutzeravatar
dummy
Kámi-sama
Kámi-sama
Beiträge: 556
Registriert: 29.12.2007 10:35
Gruppe: ASU
Wohnort: kleiner Satellit, hinterm Mond
Kontaktdaten:

Re: Video Player

Beitragvon dummy » 26.02.2008 01:46

Danke, dass ihr euch mit der Sache beschäftigt. Ich werde vielleicht mal wieder formatieren, vielleicht verschwindet dieses Problem danach.
Bild Bild Bild
Ich mag Photoshop ^^.


Zurück zu „Support für PC und Notebook“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast